Binary Viewer Loading File

There are three ways of loading a file into Binary Viewer:
  • Command Line - DataViewer.exe myfile.xyz. If you use DataViewer for some data type a lot, you can associate DataViewer with that data type file extension.
  • Use "Open" icon on the toolbar or "Open" menu item in File menu
  • Open file As - if you know your file type, you can select it in OpenAs submenu. This option is handy in rare cases when DataViewer has hard time auto-detecting data file type.

 
Here is how Open As submenu looks like:
 

 
List of available formats depends on set of binary data definition files installed in the system. You can open the folder with binary data definition files from Tools menu - "Open Data definitions folder".
 
You are welcome to modify binary data definition files and create your own ones. You can download recent and experimental versions of data definition files from community web site BinoPedia.org. All the files listed on this web site are covered by license CC BY-SA. It means, that you can use binary data definition files created by community in your non-commercial and commercial projects. We encourage you to upload upload your new and modified binary data definition files to the BinoPedia. Your efforts will be appreciated by many people.
 
When you work on binary data definition files, you often need to test your changes. You have two options: either put and edit the file in the standard data definition files folder, or load it from some other location. In the first case, you can use "Reload data definitions" menu item in the Tools menu. It will reload all data definitions, then reload your file. "Load data definition file" in the Tools menu is for the second case. It just loads a binary data definition file you choose.

Help Topics: