Binary Viewer Loading File

There are three ways of loading a file into Text Viewer:
  • Command Line - TextViewer.exe myfile.xyz. If you use TextViewer for some data type a lot, you can associate TextViewer with that data type file extension.
  • Use "Open" icon on the toolbar or "Open" menu item in File menu
  • Open file As - if you know your file type, you can select it in OpenAs submenu. This option is handy in cases when TextViewer is unable to auto-detect correct file type.

 
Here is how Open As submenu looks like:
 

 
List of available formats depends on set of binary data definition files installed in the system. You can open the folder with binary data definition files from Tools menu - "Open Data definitions folder".
 
When you work on text data definition files, you often need to test your changes. You have two options: either put and edit the file in the standard data definition files folder, or load it from some other location. In the first case, you can use "Reload data definitions" menu item in the Tools menu. It will reload all data definitions, then reload your file. "Load data definition file" in the Tools menu is for the second case. It just loads a text data definition file you choose.

Help Topics: